Install lamp server on Aliyun Ubuntu

×

Error message

Deprecated function: The each() function is deprecated. This message will be suppressed on further calls in _menu_load_objects() (line 569 of /homepages/46/d762693627/htdocs/dc/includes/menu.inc).
Install lamp server on Aliyun Ubuntu

Run the following commands to install LAMP server

sudo apt-get update
sudo apt-get install tasksel
sudo tasksel install lamp-server

Run the following command to install phpmyadmin

sudo apt-get install phpmyadmin
  • For the server selection, choose apache2.
  • Select yes when asked whether to use dbconfig-common to set up the database
  • You will be prompted for your database administrator's password
  • You will then be asked to choose and confirm a password for the phpMyAdmin application itself
sudo ln -s /usr/share/phpmyadmin /var/www/html

The command above is to move phpmyadmin into right place.

The only thing we need to do is explicitly enable the php5-mcrypt extension, which we can do by typing:

sudo php5enmod mcrypt

If you are using php7 run the following command to install mbstring.

sudo apt-get install php7.0-mbstring

Afterwards, you'll need to restart Apache for your changes to be recognized:

sudo service apache2 restart

You can now access the web interface by visiting your server's domain name or public IP address followed by /phpmyadmin: http://domain_name_or_IP/phpmyadmin

sudo apt-get install git

 

blog tag: